25 Ağustos 2011 Perşembe

Internet Explorer Açılış Sayfasının Değişmemesi Problemini Düzeltmek

Öncelikle bilgisayarınızı Malware Byte's Anti Malware ya da Ad-aware gibi yazılımlar ile malware lere karşı tarayın. 
 
Internet başlangıç sayfasını değiştiremiyorsanız (yani ayarlarda silikseve aktif halde görünmüyorsa ) registrydeki

HKEY_CURRENT_USER\Software\Policies\Microsoft\
Internet Explorer\Control Panel anahtarını açın. Sağ tarafta bulunan HomePage REG_DWORD 0X00000001(1) değerin-
deki parantez içindeki (1) değerini (0) olarak değiştirin.


Ayarlarda başlangıç sayfası değişimi aktif hale geliyor fakat hala giriş sayfasını değiştiremiyorsanız;

HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main i açın sağ tarafta bulunan start page ve search page
deki yazan sayfa adreslerini kontrol edin. Çift tıklayarak dilediğiniz sayfa adreslerini girebilirsiniz

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main anahtarını açın sağ tarafta bulunan start page ve
search page deki yazan sayfa adreslerini kontrol edin. Çift tıklayarak dilediğiniz sayfa adreslerini girebilirsiniz.

Elastix Default Password

admin
palosanto

admin
admin

admin
password

admin
mypassword

Iptables Konfigürasyonu

Iptables Firewall Ayarlarını Kaydetmek


Iptables ayarlarını iptables-sace komutu ile saklayabilirsiniz ve bir sonraki
reboot'ta iptables-restore ile geri çağırabilirsiniz.
Kullanımına dair örnek şu şekilde :

# iptables-save > /root/iptables

Bu komut ile kullanımda olan firewall kuralları /root/iptables dosyasına yazılır.
Eğer istenirse başlangıçta otomatik olarak çalıştırılacak şekilde ayarlanabilir.

Red Hat sistemlerde bu dosya /etc/sysconfig/iptables yoluna kopyalanırsa
bilgisayar yeniden başlarken bu kurallar çalıştırılır. Eğer otomatik olarak
çalışmazsa elle şu şekilde çalıştırabilirsiniz :

# iptables-restore < /root/iptables

Bu şekilde daha önceden kaydedilmiş olan kurallar kernel'a yeniden yüklenmiş olur.

VNC Server Konfigürasyonu

VNC üzerinden KDE veya GNOME Başlatılması


  1.  ~/.vnc/xstartup dosyasını bir text editorü ile editleyin.
  2. "# unset SESSION_MANAGER" ve "# exec /etc/X11/xinit/xinitrc" satırlarının başındaki "#" işaretini kaldırın.
  3. KDE için, sondaki "twm &" yerine "startkde &" yazın.
  4. Gnome için, "twm &" yerine "exec gnome-session &" yazın.
  5. Mevcut vncserver desktoplarını "vncserver -kill :xxx" komutu ile killeyin. xxx display numarasıdır.
  6. "vncserver" diyerek yeni bir vnc oturumu açın.

VNC Server Konfigürasyonu


#service vncserver start
#vncpasswd
Password: 
Verify:
#vncserver

New 'demo.netpedi.com:1 (cagri)' desktop is demo.netpedi.com:1

Creating default startup script /home/cagri/.vnc/xstartup
Starting applications specified in /home/cagri/.vnc/xstartup
Log file is /home/cagri/.vnc/demo.netpedi.com:1.log

MySQL Ayarları

Veritabanı Oluşturma


Mysql'e root ile bağlanmak:
mysql -u root -p

Database oluşturma:

mysql> create database testdb;

Oluşturulan database üzerindeki tüm hakları bir kullanıcıya vermek için:

mysql> grant all on testdb.* to user@localhost identified by 'password';
mysql> flush privileges;

Oluşturulan database üzerinde sadece okuma hakkı vermek için:
mysql> grant select on testdb.* to user@localhost identified by 'password';
mysql> flush privileges;

Oluşturulan database üzerindeki tüm hakları var olan bir kullanıcıya vermek için:
mysql> grant all on testdb.* to user@localhost;
mysql> flush privileges;

VirtualBox CLI'dan VM Çalıştırma

VBoxManage startvm [vmname]

Ubuntu Debian Paket Yönetimi

dpkg-query komutu

dpkg-query [option...] command

Option :
-l, --list : Verilen dokuya uyan paketleri listeler. Örn: dpkg-query -l 'mysql*'
-L, --listfiles : Verilen paket-ismine göre kurulu olan dosyaları listeler: Örn: dpkg-query -L mysql-server-core-5.1
-s, --status : Verilen paketin durumunu görüntüler. Örn: dpkg-query -s mysql-server-core-5.1
-S, --search : Verilen dosya ismini kurulu olan paketler içinde arar. Örn: dpkg-query -S mysql

.deb Paket kurulumu


  • dpkg --install [filename].deb
  • dpkg -i [filename].deb

CUPS Port

http://127.0.0.1:631

Bir sistemi açılışta samba paylaşımlarını otomatik mount etmesi için ayarlamak

/etc/fstab dosyasına şu komut girilir:

//ntserver/docs /mnt/samba smbfs username=docsadm,password=D1Y4x9sw 0 0

Windows paylaşımlarını Linux'da mount etmek

Mount edilecek klasör root hakları ile oluşturulur.

# mkdir -p /mnt/ntserver
Mount etmek için şu komutlar kullanılır.

# mount -t cifs //ntserver/download -o username=vivek,password=myPassword /mnt/ntserver


RHEL 4 den ve Debian 3 den eski versiyonlar için şu komutlar kullanılmalıdır.

# mount -t smbfs -o username=vivek,password=D1W4x9sw //ntserver/download /mnt/ntserver


Komutların anlamları:

  • -t smbfs : Mount edilecek dosya sisteminin tipi. (eski)
  • -t cifs : Mount edilecek dosya sisteminin tipi. (yeni)
  • -o : Kullanıcı adı ve şifre gibi opsiyonları girebilmek için kullanılacak parametre.
Detaylı bilgi için " man mount.cifs "

Linux Konsoldan Shadow Password Üretmek

Code :

echo "KriptolanmamışŞifreniziBurayaGirin" | perl -nle 'print crypt($_, "\$1\$".join "", (".", "/", 0..9, "A".."Z", "a".."z")[rand 64, rand 64, rand 64, rand 64, rand 64, rand 64, rand 64, rand 64]);'

Linux Saat Ayarı

Software Saati Ayarı:

date -s "08/21/2007 09:05:00"
Software Saatini Hardware Saatine Yazmak İçin:

clock -w

Lokal Yazılım Saatini Görmek İçin:
date +%c

Universal Yazılım Saatini Görmek İçin:

date -u +%c

Linux Sistemin Açık Kalma Süresini Öğrenmek

  • Sistem Uptime
less /proc/uptime

Linux Komut Satırından Klasör ve Dosya Boyutunu Görüntüleme

  • Klasör ve dosya boyutunu okunabilir düzeyde görüntüleme
du -sh

Linux Bellek Kullanımı, Disk Kullanımı ve İşlemci Bilgileri

  • Bellek Kullanımı MB Cinsinden:
$free -m

less /proc/meminfo
  • Disk kullanımı Human Readable:
$df-h
  • İşlemci bilgileri:
$less /proc/cpuinfo

Linux Çekirdek Versiyonu ve Sürümünü Öğrenmek

  • Çekirdek versiyonu
$uname -a
less /proc/version
  • Linux Sürümü
$cat /etc/*-release

Linux IP Adres Konfigürasyonu

1- Önce network-scripts klasörü atına gidiyoruz. Interface bilgileri burada tutulmaktadır.
            

#cd /etc/sysconfig/network-scripts
2- ifcfg- ile başlayan dosyaları listeliyoruz ve hangi interface'in konfigürasyonu yapılacaksa dosya ismi sonunda interface'in adı yazan dosyayı düzenleyeceğiz.

#ls ifcfg-*

3- ifcfg-eth0 dosyası içinde gerekli düzenlemeleri yapıyoruz.

#vi ifcfg-eth0
  Dosyanın içeriği şu şekilde.


DEVICE=eth0
BOOTPROTO=none
BROADCAST=192.168.1.255
HWADDR=00:21:85:97:7c:47
IPADDR=192.168.1.210
NETMASK=255.255.255.0
NETWORK=192.168.1.0
ONBOOT=yes
DNS1=192.168.1.1
DNS2=4.2.2.2
GATEWAY=192.168.1.1
TYPE=Ethernet


4- eth0 interface'ini up ediyoruz

#./ifup ifcfg-eth0

5- Default Gateway ifcfg-eth0 dosyasında yazılı ancak manuel olarakda eklenebilir.

#route add default gw 192.168.1.1


6- Name Server (DNS) resolv.conf dosyası içine yazılır.

#vi /etc/resolv.conf
  Dosya içeriği şu şekilde.


nameserver 192.168.1.1
7- Network servisini restart etmek için.


#service network restart

Frame Relay Konfigürasyonu

Point-ToPoint Frame-Relay
 
R1(config)#int s0/1
R1(config-if)#encapsulation frame-relay
R1(config)#int s0/1.102 point-to-point

R1(config-subif)#ip address 192.168.1.1 255.255.255.0

R1(config-subif)#frame-relay interface-dlci 102

OSPF Konfigürasyonu

router(config)#router ospf 1
(Ospf 1 process'ini router üzerinde başlatır)
 
router(config-router)#network 192.168.1.1 0.0.0.255 area 0
(192.168.1.0 networkune ait interfaceler üzerinde ospf komşuluğu kurup hello paketlerini o interfaceler üzerinden gönderir ve 192.168.1.0 interfacelerini area 0 a dahil eder)
 
router(config-router)#roouter-id 2.2.2.2
(Router-id yi 2.2.2.2 olarak ayarlar.)
 
 
router(config-router)#default-information originate
 (Default route gibi default bilgileri ospf process'i üzerinden diğer router'larada gönderir.)
 
Show ve Debug Komutları:
 
router#show ip ospf neighbor
router#debug ip ospf adj
 
router#show ip route
router#show ip protocol

Cisco DHCP Server Konfigurasyonu

  • Kullanmak istediğiniz IP Adresleri için bir pool oluşturun.
Router(config)# ip dhcp pool SIRKETPOOL
  • Pool için network ve subnet leri belirleyin.
Router(dhcp-config)# network 1.1.1.0 /8   
  • Kullanıcılar için DNS Domain adı belirleyin.
Router(dhcp-config)#domain-name mydomain.com
  • Birincil ve ikincil DNS leri belirleyin.
Router(dhcp-config)#dns-server 1.1.1.10 1.1.1.11
  • Gateway adresini belirleyin.
Router(dhcp-config)#default-router 1.1.1.1
  • Kullanıcıların ne kadar zaman sonra ip adreslerini yenilemeleri gerektiğini belirleyin
Router(dhcp-config)#lease 7
  • Pool konfigurasyon modundan çıkın.
Router(dhcp-config)#exit
  • DHCP Server'ın pool'unuzdan hangi aralıktaki ip adreslerini dağıtmayacağını belirleyin
Router(config)#ip dhcp excluded-address 1.1.1.0 1.1.1.100
  • Belirli ip lerin sürekli olarak belirli clientlara verilmesini istiyorsanız ayrı bir pool yaratıp client 'ın mac adresini girerek bu client a sürekli aynı ip adresinin verilmesini sağlayabilirsiniz.
     ip dhcp pool HP1320N
        host 1.1.1.200 255.0.0.0
        hardware-address 0014.3890.14f3

Cisco DHCP Relay Agent

A DHCP server is the one which provides a network client with a unique IP address, Subnet mask, Gateway and DNS server IP address automatically when it connects to the network.

A DHCP Relay Agent is a computer, server or a Router in a particular subnet which receives a DHCP client broadcast and relays it to a DHCP server in another network or a subnet. A DHCP Relay Agent is more a helper agent here that gets the client a DHCP lease.

Lets say there are multiple subnets in your network with DHCP clients in all being seperated and routed through a router or a firewall and that not every subnet has a DHCP server and the organisation has just one or few centralised DHCP servers.

Given that the routers do not forward IP broadcast messages from one network to another, the only way that the clients get their leases are;

1. One DHCP server in each subnet where there DCHP client exist

or

2. Use a DHCP Relay Agent which can receive and relay BOOTP and DHCP Client broadcast messages.

Most of the routers and Firewalls these days do have support for DHCP Relay Agents. In the event that you are the unfortunate one whose networks are routed using a router not supporting a DHCP Relay Agent then you can choose to use the DHCP Relay Agent support in Windows Server 2000 or 2003 or a Linux server.
 
Cisco Routers support DHCP Relay Agents with ip helper-address command. To enable the  ip helper-address on an interface that will receive client BOOTP/DHCP broadcasts.

From the Global configuration mode,

Router(config)# interface fa 0/0

Router(config-if)# ip helper-addres 10.10.10.1

Router(config-if)# ip helper-addres 10.10.10.2

NOTE: 10.10.10.1 & 10.10.10.2 are the IP Address of the DHCP server.

This will relay all DHCP broadcast messages received on interface FastEthernet 0/0 to the DHCP server 10.10.10.1

If there are more than one DHCP servers then use one helper-address for each DHCP server as above.